Firefox disabled all add-ons because a certificate expired: Update

Users who viewed this discussion (Total:1)

djbaxter

Administrator
Joined
Nov 10, 2016
Messages
1,838
Points
113
Firefox disabled all add-ons because a certificate expired
Engadget.com
May 3, 2019

Update: As of 7 AM ET May 4, 2019, a fix is now rolling out.

Many Firefox users around the world are browsing without their usual set of extensions after they suddenly stopped working earlier this evening. The event occurred as the clock rolled over on UTC (Coordinated Universal Time, aka GMT or Greenwich Mean Time), and impacted users quickly narrowed it down to "expiration of intermediate signing cert" -- as it's described on Mozilla's bug tracker.

This same problem almost happened three years ago, but "armagadd-on" 2.0 has torn things up once again. In a statement provided to Engadget, Product Lead Kev Needham said:

We're sorry that there is currently an issue where existing and new add-ons are failing to run or be installed on Firefox. We know what the issue is and are working hard to restore add-on functionality to Firefox as soon as possible. We'll continue to provide updates via our Twitter channels. Please bear with us while we get the problem fixed.
For now, there is at least one workaround, but it only applies if you're using the Firefox Developer or Nightly build. If you look under "about:config" (if you don't know what this is, you probably shouldn't try it) and set the "xpinstall.signatures.required" value to False, then your extensions will start working again.

Update: If you're on another version of Firefox, there is a way to temporarily fix it, but you'll have to repeat it every time you reopen the browser. It involves enabling add-on debugging and manually loading each extension's .xpi file.
Update 3 (5/4, 7:30 AM ET): The team has announced a hotfix is rolling out now. It's applied in the background, so you shouldn't have to do anything to receive it. However, to make sure you get it right away, you can follow these instructions:
In order to be able to provide this fix on short notice, we are using the Studies system. You can check if you have studies enabled by going to Firefox Preferences -> Privacy & Security -> Allow Firefox to install and run studies.
You can disable studies again after your add-ons have been re-enabled.
Read more...
 

djbaxter

Administrator
Joined
Nov 10, 2016
Messages
1,838
Points
113
Firefox has released an update fixing the problem.Firefox has released an update fixing the problem.
 
Top